Unable to autoping agent but jobs run successfully
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Article ID: 111153
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Updated On:
Products
CA Workload Automation AE - Business Agents (AutoSys)CA Workload Automation AE - Scheduler (AutoSys)CA Workload Automation Agent
Issue/Introduction
A new agent in an AWS envrironment is not responding to autoping command, but can successfully process batch jobs without issues.
autoping -m t11475 CAUAJM_I_50023 AutoPinging Machine [t11475] CAUAJM_W_10496 Agent on [t11475] has not responded in a timely fashion. Try again later. [CA WAAE Autoping] CAUAJM_E_50281 AutoPing from the Scheduler WAS NOT SUCCESSFUL.
CAUAJM_W_10496 Agent on [t11475] has not responded in a timely fashion. Try again later. [CA WAAE Autoping] CAUAJM_E_50283 AutoPing from the Application Server WAS NOT SUCCESSFUL.
CAUAJM_E_50026 ERROR: AutoPing WAS NOT SUCCESSFUL.
Cause
There are several reasons why an agent would not be able to communicate with a scheduling manager. Most of the time it is network related in that either a port is closed, or in this particular case, the server name could not be resolved by the network.
Environment
Release: Component: ATSYS
Resolution
Adding IP address and the name of the agent to the scheduling managers host file as well as adding the scheduling manager IP address and name to the respective hosts file should address this issue as your servers are likely not managed by your DNS.