Clarity: Network error occurs when download jasper reports as pdf file with Chrome browser.

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Article ID: 111005

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

STEPS TO REPRODUCE 

1. Open any report in Advanced Reporting with Chrome browser. 
2. Export the report and use PDF option. 

Expected Results: Downloading PDF file is successful with Chrome browser. 
Actual Results: Downloading PDF file returns network error with Chrome browser. 

Cause

This was reported as a defect DE41673 however this is determined this is not a defect with Clarity or Jaspersoft but change in behavior with Chrome. Here is the information https://support.google.com/chrome/answer/6213030?hl=en

Environment

Clarity 15.x with Jaspersoft 7.1 using Chrome 69.0.3497.100

Resolution

Chrome:

- Use Print function and save as PDF instead of Download. 
- Turn on the "Download PDF files instead of automatically opening them in Chrome" option of Chrome.

Additional Information

Details of replication:

1. Open any report (ex, Project Story Board) in Advanced Reporting with Chrome browser.
2. Use PDF option.

3. Click Download icon.  It returns NetWork error.

Attachments