Can't Start IdentityGovernance Service
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Can't Start IdentityGovernance Service

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Article ID: 111002

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction

When starting the Identity Governance it is failing. The failing message lists a table which does not exust:
"SELECT ssid, Name, CreateDate, Owner, Description, Type, ExtractionComplete, ExtractionFailed FROM RCM_Snapshots ]; nested exception is java.sql.SQLException:
...
table or view does not exist "

Environment

Identity Governance 14.0 and up

Cause

This is caused by a property wrongly set.
The property of 'reportdb.enabled' need to be set to 'false'.


 

Resolution

Since modifying the property is not possible through the web UI(the server is not starting), it will have to be modified directly in the database.
Engage your DBA in order to modify the SAGE_PREFERENCES table and change the VALUE column to 'false' where the NAME column equals 'reportdb.enabled'.