UC4.SMD file corrupted
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UC4.SMD file corrupted

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Article ID: 110982

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Multiple modifications to the Service Manager Dialog entries will cause the "uc4.smd" file to become corrupted.

The Service Manager will be impacted the next time it is stopped and started.  The CPs and WPs will not start due to no primary work process (PWP) being registered in the database.

 

Environment

Release: 12.x
Component: Automation Engine

Cause

SET-PROCESS-DATA-V2 command to ServiceManager contains new path:

TRACE: (Command) 0x7ffdd0581ed0 001008
 00000000 F0031400 55433420 52415F57 45425F30 >ð...UC4 RA_WEB_0<
 00000010 31000000 00000000 00000000 00000000 >1...............<
 00000020= 00000000 00000000 00000000 00000000 >................<
 00000040 00000000 00000000 2F6F7074 2F617574 >......../opt/aut<
 00000050 6F6D6963 2F6A646B 2F62696E 2F6A6176 >omic/jdk/bin/jav<
 00000060 61202D58 6D783531 324D202D 446A6176 >a -Xmx512M -Djav<
 00000070 61782E6E 65742E73 736C2E74 72757374 >ax.net.ssl.trust<
 00000080 53746F72 653D2F6F 70742F61 75746F6D >Store=/opt/autom<
 00000090 69632F6A 646B2F6C 69622F73 65637572 >ic/jdk/lib/secur<
 000000A0 6974792F 63616365 72747320 2D586D78 >ity/cacerts -Xmx<
 000000B0 32303438 4D202D6A 6172202F 6F70742F >2048M -jar /opt/<
 000000C0 6175746F 6D69632F 53657276 6963654D >automic/ServiceM<
 000000D0 616E6167 65722F62 696E2F2E 2E2F2E2E >anager/bin/../..<
 000000E0 2F416765 6E74732F 72615F77 65625F30 >/Agents/ra_web_0<
 000000F0 31322F62 696E2F75 63786A63 6974782E >12/bin/ucxjcitx.<
 00000100 6A617220 64697361 626C655F 63616368 >jar disable_cach<
 00000110 65000000 00000000 00000000 00000000 >e...............<
 00000120= 00000000 00000000 00000000 00000000 >................<
 00000240 00000000 00000000 2F6F7074 2F617574 >......../opt/aut<
 00000250 6F6D6963 2F536572 76696365 4D616E61 >omic/ServiceMana<
 00000260 6765722F 62696E2F 2E2E2F2E 2E2F4167 >ger/bin/../../Ag<
 00000270 656E7473 2F72615F 7765625F 30312F62 >ents/ra_web_01/b<
 00000280 696E0000 00000000 00000000 00000000 >in..............<
 00000290= 00000000 00000000 00000000 00000000 >................<
 00000370 C7E20FC8 FAC4D1C1 2AFE53C9 C8FD40EB >Çâ.ÈúÄÑÁ*þSÉÈý@ë<
 00000380 8BDF0F6B 2837C79E A6E75F95 01935123 >‹ß.k(7ÇΕΎ¦ç_•.“Q#<
 00000390= 00000000 00000000 00000000 00000000 >................<
 000003B0 31000000 00000000 00000000 00000000 >1...............<
 000003C0= 00000000 00000000 00000000 00000000 >................<
 000003E0 0000F003 00000000 00000000 00000000 >..ð.............<
20180613/171914.377 - Command: SET-PROCESS-DATA-V2

Looks like Service Manager is making some wrong changes in the smd file.

Resolution

Upgrade Service Manager to one of the following fixed versions:

Automation Engine 12.3.0 - Available
Automation Engine 12.2.1 - Available
Automation Engine 12.1.3 - Available
Automation Engine 12.0.6 - Available

Workaround:
Create a backup of the working smd file.  Use the backup file as a restoration point whenever the smd becomes corrupted.