Gen 8.6 Client Manager "Failed to load DLL IEFCMN, reason code 126"
search cancel

Gen 8.6 Client Manager "Failed to load DLL IEFCMN, reason code 126"

book

Article ID: 110651

calendar_today

Updated On: 05-13-2024

Products

Gen Gen - Run Time Distributed

Issue/Introduction

Upgrading from Gen 7.6 to Gen 8.6 and experiencing 3 problems when using the Client Manager (CM): 

1. Every time CM starts it displays the "Client Manager Customization" dialog to specify the language 

2. If start as administrator and specify the language can use the CM but when close it down and restart then it displays the error:
Failed to load DLL IEFCMN, reason code 126

3. When sending a test transaction, it works OK but displays the message:
Message load failure, id = 16034, error 1813

Environment

Release: 8.6
Gen Client Manager

Cause

A custom install shield is being used to deploy the Client Manager into a custom directory.

The error "Failed to load DLL IEFCMN, reason code 126" normally means a dependent dll cannot be found.
To troubleshoot, it is often best to use Dependency Walker 2.2 on the problem dll (in this case IEFCMN.dll) to determine the missing dependent dll.
However in this case Dependency Walker did not help.

1. Check the PATH settings in Windows (i.e. Control Panel > System > Advanced system settings > Environment Variables) - is the CM deployment directory in the system path? 
2. Check the file iefcmn.ini content validity.

Resolution

The root cause was that file iefcmn.ini had an incorrect full path for property MSGDLLNAME.
The default value is "C:\Program Files (x86)\CA\Gen86\Gen\\commrt\cmw32\CMMSGENGn.dll".

Additional Information