Identity Manager - Time and Date not in the correct format
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Article ID: 110233
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Updated On:
Products
CA Identity ManagerCA Identity GovernanceCA Identity Portal
Issue/Introduction
The Date is displayed with wrong format, YYYY-MM-DD HH:MM:SSZ instead of DD/MM/YYYY, and time is displayed always in Zulu time (GMT 0) instead of local time.
Environment
Identity Manager 12.x, 14.x
Cause
There are two rule strings available for Date and Time:
%XD% which returns a value in the dateTimeValue format, this is a UTC value such as "2018-05-23T11:52:40Z" regardless of the OS configured timezone of the Provisioning Server.
%D% which returns a value in the format of dd/mm/yyyy without Time.
The only rulestring available in the Provisioning Server related to timestamp is %XD% which returned a UTC value such as "2017-09-14T11:52:40Z" even though the Provisioning Server is running on a Windows OS configured with UTC-5 Eastern Time and had the clock set to 8:00am, the time returned by %XD% will be 1:00pm
If you need the Provisioning Server to have a rulestring to get the date/time in local server time versus UTC time you can open an idea in the CA Communities.
Resolution
For date format, you need to use rule string %D%
For Time, you can use Policy Xpress. In the Data tab, In Category select Date and Time, in Type select Time, and Function selects Current Time.
If you still need a rule string with this option, please open an enhancement request