Delayed Server Response on the Quick Profile page
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Delayed Server Response on the Quick Profile page

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Article ID: 110046

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager ServiceDesk

Issue/Introduction

When using a non-administrative role, and viewing the profiles of certain users with the Quick Profile functionality, you may receive Delayed Server Response messages. Alternatively, the Quick Profile page may load after a very long delay, but the frames loaded may be incomplete or missing buttons and content. This does not occur when using an administrative role, or when viewing the profiles of most contacts. Viewing the normal contact details page of an affected contact still works as intended.

Environment

CA Service Desk Manager All Versions

Cause

If the affected user is set to use the Problem Manager role, and also has their preferred document type set to Problem, a very long-running query is launched when the Quick Profile view is opened. In sufficiently large environments, this query may return more than 999,999 results, at which time the query terminates and the frames do not finish loading their content correctly.

Resolution

There are several potential resolutions here:

  • Change the affected user's default role to an unaffected role.
  • Change the affected user's preferred document type.
  • Use Archive and Purge to remove outdated ticket data from the system, which will cause the query to return fewer results and complete on time.
  • Modify the files profile_browser.js and profile_menu.htmpl to change the on-load queries.

Additional Information

In another instance where the above-described problem happened, he rebooted the Service Desk Server and did not see the problem again.  It is unconfirmed if the root cause was the same or different.  But if experiencing this problem, it is something to try.