Virtual Appliance Connection to database failed
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Virtual Appliance Connection to database failed

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Article ID: 110041

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal

Issue/Introduction


 Your_Database_FQDN external-DB [ERROR] Connection to IM database (Your_Database_FQDN:1433) failed 
 Your_Database_FQDN external-DB [ERROR] Connection to IP database (Your_Database_FQDN:1433) failed 
 Your_Database_FQDN external-DB [ERROR] Connection to IG database (Your_Database_FQDN:1433) failed 

 

Environment

Virtual Appliance 14.x

Cause

While monitoring a system with an external DB, the vApp monitor will try to verify network reachability to the DB.
This operation has a timeout of 3 seconds.

Due to some network latency, this message is logged in.

Resolution

To check the TCP connection between vApp Server and Database, run the phyton script attached.

phyton python_check_tcp.py <IP> <port>
phyton  python_check_tcp.py <FQDN> <port>

Use the same FQDN used in your vApp configuration

If your environment is using FQDN and it takes more time than IP, check your network about a possible problem with name resolution or you can add the FQDN in your hosts file.

 

Attachments

1558536661659python_check_tcp.py get_app