Advanced Reporting not working after configuring HTTPS access for Jaspersoft
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Advanced Reporting not working after configuring HTTPS access for Jaspersoft

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Article ID: 110030

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After configuring HTTPS access for Jaspersoft, accessing the reporting tool via Home > Personal > Advanced Reporting displays the options but clicking into any of them does not do anything. You are unable to execute reports due to this issue.

Reviewing the Jaspersoft logs, entries such as the below are found:

2018-08-07 17:01:18,351 ERROR CsrfGuard,https-openssl-nio-x.x.x.x-x-exec-1:44 [x|x] - potential cross-site request forgery (CSRF) attack thwarted (user:<anonymous>, ip:x.x.x.x, method:POST, uri:/x, error:required token is missing from the request)

Environment

Release: Any

Cause

When using Clarity integrated with Jaspersoft, you cannot use both HTTP and HTTPS SSL (Mixed Mode) Handling for Clarity

Resolution

  1. On the CSA > [server] > Properties > Application > Application Server, check the current value for SSL Handling. If you are using HTTPS access with Jaspersoft, change it to "Support only HTTPS".
  2. Also, make sure that the HTTPS Entry URL for the app server matches the one you enter in the browser to access Clarity.
  3. Restart app services after making the above changes.

Additional Information

See also: Advanced Reporting UI stuck with 'Please Wait' message