SUPPORT AUTOMATION- SERVERCA Service Desk Manager - Unified Self ServiceKNOWLEDGE TOOLSCA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
End users are noticing JNLP files not being launched automatically when an analyst tries to launch the Support Automation interface from a Chrome browser.
Cause
Chrome no longer supports NPAPI (technology required for Java applets). The Java plug-in for web browsers relies on the cross platform plugin architecture NPAPI, which has been supported by all major web browsers for over a decade. Google's Chrome version 45 (scheduled for release in September 2015) drops support for NPAPI, impacting plugins for Silverlight, Java, Facebook Video and other similar NPAPI based plugins.
On the other hand, Chrome does not allow enabling the option "Always open files of this type" when opening a JNLP file.
This option is greyed out for JNLP files.
Environment
CA Service Desk 17.1 CA Service Desk 17.0
Resolution
Consider opening JNLP files manually (analystUI.jnlp) or using another browser when running Support Automation.