RPT-0022 for Reports due to missing Access

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Article ID: 109882

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

Users receive an RPT error 0022 (Error 'RPT-0022: You do not have proper privileges to run the report' when trying to run reports within Clarity)

One example this may be seen with: running the Timesheet Detail Report

Cause

This may be caused by missing access rights in either Clarity or on the Advanced Reporting folder.

Environment

Release: Clarity 15.3 and higher
Component: Clarity Jaspersoft

Resolution

  1. Verify the user has the below Clarity access rights:
  2. If the user has these rights already, see if the report can be run from within Advanced Reporting.
  3. Check to ensure the user is assigned to the appropriate role / group to run the report. Example, to run the Timesheet detail report, or any other PMO Timesheet report, the user needs to be assigned to the CSK_ROLE_TIME_MANAGEMENT role in Advanced Reporting (Which can be granted by adding the user to the Clarity access group: PMO Advanced Reporting Time Management group then running the Synchronize Jaspersoft Roles job)
  4. If the report or folder cannot be seen in Advanced Reporting (It's  recommended to first try all the steps above, as best practice is to not change folder permissions in Advanced Reporting)
    • Check the Role_User rights on the folder and make sure the Role User has Read+Write access to the folder.
    • Make sure Role_User has read rights to the following folder: CA PPM Reports Output
      1. Go to Home->Advanced Reporting
      2. Click on View from the Advanced Reporting toolbar / menu and then click Repository
      3. On the left hand folders window, expand the top level folder and right click on CA PPM Reports Output
      4. Select Permissions
      5. Change ROLE_USER permissions to Read only
      6. Run the Create and Update Jaspersoft users job

Additional Information

KB: Granting rights to run reports from Reports and Jobs but not Advanced Reporting

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