Need 64 bit version of ArcotSiteMinderAdapter - because of Siteminder server upgrade to 12.8

book

Article ID: 109868

calendar_today

Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

 

I'm upgrading a Policy Server to 12.8, and I'd like to get a download
link to update ArcotSiteMinderAdapter component in my current 6.0
version. I'm aware of this issue because the Policy Server 12.8
installer was reporting at run time the following message :

  The Upgrade Readiness utility has identified potential issues.
  Remove or upgrade (to a 64-bit version) the identified custom components after
  the upgrade completes. Starting the Policy Server without doing so will likely
  result in errors. See the documentation for more information about the
  utility.

  Custom Binaries that are configured and available in lib or bin
  ================================================================
  Binary Name: ArcotSiteMinderAdapter
  Object Name: ArcotMfa
  Object Type: Authentication Scheme
  Object Path: AuthScheme[ArcotMfa]
  Binary Path: /opt/CA/siteminder/lib/libArcotSiteMinderAdapter.so
  Description: 32-bit binarys
  ________________________________________



How can I get the correct binaries?

 

Environment

 

Policy Server 12.8SP5 on RedHat 7;
Advanced Authentication 6;

 

Resolution

 

You will have to upgrade the CA Adaptor to version 8.x or 9.0. The
version 6.2.0.2 is out of support with Policy Server 12.8.

  Configuring CA Single Sign-On Policy Server 

    In the Scheme Setup section of the Create Authentication Scheme 
    screen, perform tasks that are mentioned: Enter the Adapter library 
    file name as ArcotSiteMinderAdapter in the Library field. 

  https://techdocs.broadcom.com/us/en/symantec-security-software/identity-security/advanced-authentication/9-1/installing/ca-adapter-installation/configuring-ca-single-sign-on-policy-server.html

According our Platform Support Matrix, Policy Server 12.8 is supported
with Advanced Authentication 8.x and 9.0 :

  Platform Support Matrix CA Single Sign-On 12.8

    4.3 Security Product Compatibility

      | Product                     | Version       | SiteMinder     |
      |                             |               | Policy Server  |
      |                             |               | Operating      |
      |                             |               | System         |
      |-----------------------------+---------------+----------------|
      | Symantec (previously CA)    | 8.x, 9.0, 9.1 | Windows Server |
      | Advanced Authentication (   |               | 2016, 2012R2   |
      | Strong Authentication, Risk |               |                |
      | Authentication) Adapter     |               | RHEL 6,7       |

    p.12

  https://ftpdocs.broadcom.com/WebInterface/phpdocs/7/5262/5262-12-8-platform-support-matrix.pdf