RA Banner Agent does not start after changing database password

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Article ID: 109831

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Updated On:

Products

CA Automic Workload Automation - Automation Engine AUTOMIC WORKLOAD AUTOMATION

Issue/Introduction

After changing the password for the Banner database user Banworx, the RA Banner Agent fails with the following error in the logs:

20180801/163427.842 - U02000107 Connection object 'CONN.NAME' with time stamp '1533155624000' was successfully transferred to the Agent. 
20180801/163443.282 - Database login error 
20180801/163443.282 - Error connecting to the database. Check the JDBC login assigned to the agent and verify that it is correct. 

A forced stack trace is created with the error: 

java.sql.SqlRecoverableException: IO error: Connection reset
 

Cause

Either the connection object passwords have not been changed, or the password is cached in the jdbc. 

Environment

Release: AOMWSA99000-3.X-Automic Operations Manager-Web Services Base-Pack Agent (Incl. 5
Component:

Resolution

Ensure that the passwords are changed in the connection objects. If this has already been done, then load a fresh JDBC following the steps below:

-Stop the RA Banner Agent
-Navigate to the Agent's bin/lib directory
-Copy the jdbc jar file to another folder as a backup
-Download the relevant .jar file for the database being used
-Delete the old file and replace it with the new jdbc jar file
-Restart the Agent