net-connect probe is not getting a port
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net-connect probe is not getting a port

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Article ID: 109721

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

net_connect probe is failing to get a port.  All that appears in the log at loglevel 5 is:

nc: ****************[ Starting ]****************
nc: net_connect version 3.32, Jan 31 2017
nc: Nimsoft Corporation
net_connect: Checking no migration will be performed in this run
nc: port=48029, PID=8124
nc: Before CreateEvent
nc: After CreateEvent
nc: Before LoadMessages
nc: After LoadMessages
nc: Before LoadProfiles

Environment

UIM 8.51
net_connect probe:  any version through 3.33 GA release

Cause

net_connect.cfg file corruption.  In this case, the net_connect.cfg file contained the following corrupted device profile:

<UCAS-5585X>
   <chain>
      <admin>
         <chain>
            <pri>
               <chain>
               </chain>
            </pri>
            <sec>
               <chain>
               </chain>
            </sec>
         </chain>
      </admin>
   </chain>
</UCAS-5585X>

Resolution

If the corrupted section of the net_connect.cfg file can be easily identified, then deactivate the probe, delete the problematic section.from a text editor or the probe's Raw Configure GUI, then activate the probe again.

If it is not possible to identify the corrupted section of the net_connect.cfg file, then the only option is as follows:

1.  Delete the net_connect probe
2.  Delete the net_connect probe directory and its contents from the robot
3.  Deploy a new copy of the net_connect probe
4.  Manually add back all of the monitoring profiles from the probe's Configure GUI