Submit button gets grayed out (disabled) and the ticket cannot be submitted in CA Service Catalog 17.1 Rollup 1
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Article ID: 109704
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Updated On:
Products
CA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
When clicking on submit for a service offering which has attachment as mandatory and missing the attachment, the submit button gets grayed out (disabled) and the ticket cannot be submitted.
Steps to reproduce:
1. Log into Service Catalog 17.1 RU 1 2. Home > Service Offerings > Select Offering > Definition tab > Edit Service Option > Check "Attachment Mandatory" 3. Create a request using the offering above and miss the attachment. See the error message at the top with "To submit this request, you must add an attachment to the service option(s) . Use the Attachment icon of the service option" and the submit button is grayed out.
The following error appears in console when reproducing issue:
Uncaught ReferenceError: enableButtons is not defined at sendback (wpf?Node=icguinode.catalogitemdetails&Args=10201&ObjectID=10201&NspPath=:1923) at addtocart (wpf?Node=icguinode.catalogitemdetails&Args=10201&ObjectID=10201&NspPath=:1720) at finish (wpf?Node=icguinode.catalogitemdetails&Args=10201&ObjectID=10201&NspPath=:2199) at finishaddandcheckout (wpf?Node=icguinode.catalogitemdetails&Args=10201&ObjectID=10201&NspPath=:2092) at HTMLInputElement.onclick (wpf?Node=icguinode.catalogitemdetails&Args=10201&ObjectID=10201&NspPath=:1)
Environment
CA Service Catalog 17.1 Rollup 1
Cause
Defect with Service Catalog 17.1 Rollup 1
Resolution
This is a known defect with the application and there is a test fix available. Please submit a ticket with Support to get the fix.