Upgrade Secure Cloud On-Premise Connector Server Failed
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Upgrade Secure Cloud On-Premise Connector Server Failed

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Article ID: 109325

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Updated On:

Products

CA Risk Analytics CA Secure Cloud SaaS - Arcot A-OK (WebFort) CLOUDMINDER ADVANCED AUTHENTICATION CA Secure Cloud SaaS - Advanced Authentication CA Secure Cloud SaaS - Identity Management CA Secure Cloud SaaS - Single Sign On

Issue/Introduction

Upgrading the Secure Cloud On-Premise Connector Server from version 1.58 to version 1.60 failed.

Environment

Secure Cloud 1.60

Cause

As part of previous Secure Cloud 1.58 hotfix steps the eta2_server certificate was imported into the ssl.keystore used by the Secure Cloud On-Premise Connector Server. This certificate caused a conflict which caused the upgrade to fail.

Resolution

1. Stop the on-premise Connector Server 

2. Take a backup of the existing ssl.keystore 

3. Remove the eta2_server alias from the ssl.keystore file being used via the following command: 
keytool.exe -v -delete -alias eta2_server -keystore ssl.keystore 

4. Start the on-premise Connector Server and verify that you are still able to see endpoint account details via the Secure Cloud Web UI even with the eta2_server removed from the ssl.keystore 

5. If everything is still working properly then proceed with trying to upgrade the on-premise Connector Server from version 1.58 to version 1.60