Could not execute command: D:\Program Files (x86)\CA\Service Desk Manager\bin\pdm_d_mgr.exe
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Could not execute command: D:\Program Files (x86)\CA\Service Desk Manager\bin\pdm_d_mgr.exe

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Article ID: 109294

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Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Upgrading SDM to 17.1 on the step "Migrating CA Service Desk Manager"  generates this error, "SDM Migration failed with exitcode:231.  Please refer to log file."  

stdlog shows the following:

pdm_d_mgr 3536 EXIT mgr_os_if.c 2458 : Could not execute command: D:\Program Files (x86)\CA\Service Desk Manager\bin\pdm_d_mgr.exe -w -m D:\Program Files (x86)\CA\Service Desk Manager\site\r17_0_pdm_startup.dat error: 193 

pdm_d_mgr 7108 EXIT mgr_os_if.c 2458 : Could not execute command: D:\Program Files (x86)\CA\Service Desk Manager\bin\pdm_d_mgr.exe -w -c -s DBADMIN error: 193 

Environment

Service Desk

Cause

NtfsDisable8dot3NameCreation is set to 0, but 8dot3 was not enabled on Program Files (x86)

Resolution

As a workaround to avoid uninstalling everything: 

1. Close the installer. 
2. Copy both the Service Desk Manager, and SC folders from the D drive to the C drive (any folder in C drive or other disk) and delete the folders from the D drive. 
3. Re-create the "Program Files (x86)" directory on D - which should allow it to auto create the short name of "PROGRA~1". Confirm this by opening cmd in D: and run: dir /x.
4. Copy Service Desk Manager and SC folders back to the D drive, and it should create the short names for all folders inside those directories. You can confirm this by opening cmd in D: and run: dir /x. 
5. Edit the C:\windows\paradigm.ini file to set the proper short name for the NX_ROOT directory. It should look similar to: 

[PARADIGM] 
NX_ROOT=D:/PROGRA~2/CA/SERVIC~1 
NX_LOCAL=D:/PROGRA~2/CA/SERVIC~1 

(it can be PROGRA~2 or PROGRA~1, check this by running dir /x) 

6. Restart the installer and verify it is able to complete past the migration step.