Unable to communicate to the PPM server when Gel Scripts are running
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Article ID: 108934
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Updated On:
Products
Clarity PPM On Premise
Issue/Introduction
Why do we receive the following error in the PPM interface when using the application:
"Unable to communicate to the PPM Server. Please try again and if problem persists contact your system administrator"
Cause
There can be multiple reasons for this error occurring, but one of them may relate to Gel Scripts running when this error is received.
Users have seen where this error pops up on the UI and the following error occurs in the bg-ca.log file:
"Custom script execution pool-5-thread-8] utils.Utils ----> The exception trace is too big to be attached to the process error message. Only a truncated exception trace will be attached to the process error message"
Environment
Release: All Supported Releases Component: PPMENV
Resolution
The pop up error in the UI usually goes away and does not cause any other issues, but it may be wise to run these scripts during off-hours, when there is less user-load on the system.
Additional Information
See also 191799 - Unable to Communicate to the PPM server - List of Known Issues