IJ000460: Error checking for a transaction
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IJ000460: Error checking for a transaction

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Article ID: 108924

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Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

The following error is seen during the Jboss\ Wildfly JMS system start-up hosting the CA Identity manager application server.

08:25:51,488 ERROR [ims.tmt.servercommandservice] (Thread-12 (HornetQ-client-global-threads-1629494684)) Unable to recover JMS connection 08:25:51,488 ERROR [ims.tmt.servercommandservice] (Thread-12 (HornetQ-client-global-threads-1629494684)) javax.jms.JMSException: Could not create a session: IJ000460: Error checking for a transaction at org.hornetq.ra.HornetQRASessionFactoryImpl.allocateConnection(HornetQRASessionFactoryImpl.java:876) at

Environment

Release: 14.x
Component: Identity Manager, Identity Suite

Cause

This is a DB transaction handling error.

Resolution

To correct this issue please make sure 

1. You have set the Transaction Protection to false.  To do this

Open IDM Management Console > Environment > Advanced Settings > Miscellaneous > Add Property "TransactionProtection" EQUAL to "False" 


2. Execute deleteIDMJMSQueue on all nodes to delete old journal files.  

Note: This may reboot your IM (CA IDentity Manager) server so please do this during a low traffic time.