SNMPCOLLECTOR Configuration error using admin console
search cancel

SNMPCOLLECTOR Configuration error using admin console

book

Article ID: 108922

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

When accessing the  snmpcollector probe through the admin console, we get an error:
"Configuration was unable to be retrieved"

Message: Remote Request Error: Remote / Carolinas-UIM/dcr-canet-ms-01_hub/dcr-canet-ms-01/snmpcollector probes processing of operation get_ctd_configuration failed
Resolution: Please check both the PPM and the remote probe log file for additional details
Error Code: PPM-012
Click Retry to attempt to save your configuration again.
Click Close to close this window

Log file shows:
 [DBBackup1, snmpcollector] stderr: Uncaught exception in thread DBBackup1 : com/nimsoft/probes/network/snmpcollector/database/DBBackup
Caused by: java.lang.ClassNotFoundException: com.nimsoft.probes.network.snmpcollector.database.DBBackup
java.lang.NoClassDefFoundError: com/nimsoft/probes/network/snmpcollector/ctd/GetGraphHelper
    at com.nimsoft.probes.network.snmpcollector.callback.GetCtdConfigurationCallback.getCtdConfigurationCallback(GetCtdConfigurationCallback.java:154)
Caused by: java.lang.ClassNotFoundException: com.nimsoft.probes.network.snmpcollector.ctd.GetGraphHelper

Environment

UIM 8.5
snmpcollector 3.42
 

Cause

Problem fixed in latest version of snmpcollector hotfix.

Resolution

Upgrading snmpcollector to 3.4.3 HF7 from our support site link below resolves the issue. 
https://support.broadcom.com/external/content/release-announcements/CA-Unified-Infrastructure-Management-Hotfix-Index/7233