On-Prem Services Will Not Start Due to Oracle Not Starting
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On-Prem Services Will Not Start Due to Oracle Not Starting

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Article ID: 108881

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Updated On:

Products

Rally On-Premise Rally SaaS

Issue/Introduction

When trying to start the Agile Central service in the control panel, the following error is seen numerous times in the log:

SQL*Plus: Release 10.2.0.4.0 - Production on Tue Jul 31 08:45:00 2018 Copyright (c) 1982, 2007, Oracle. All Rights Reserved. ERROR: ORA-12541: TNS:no listener Enter user-name: SP2-0306: Invalid option. Usage: CONN[ECT] [logon] [AS {SYSDBA|SYSOPER}] where <logon> ::= <username>[/<password>][@<connect_identifier>] | / Enter user-name: Enter password: ERROR ORA-12162: TNS:net service name is incorrectly specified SP2-0157: unable to CONNECT to ORACLE after 3 attempts, exiting SQL*PLUS


Logging into an ssh session and trying to start the Oracle service manually gives the following error:

[root@RallyOn-Pre-001 rc3.d]# service dbora start
ORACLE_HOME_LISTNER is not SET, unable to auto-start Oracle Net Listener
Usage: /home/oracle/app/oracle/product/11.2.0/db/bin/dbstart ORACLE_HOME
Processing Database instance "XE": log file /home/oracle/app/oracle/product/11.2.0/db/startup.log

LSNRCTL for Linux: Version 11.2.0.2.0 - Production on 31-JUL-2018 09:45:10

Copyright (c) 1991, 2010, Oracle.  All rights reserved.

Starting /home/oracle/app/oracle/product/11.2.0/db/bin/tnslsnr: please wait...

TNSLSNR for Linux: Version 11.2.0.2.0 - Production
System parameter file is /home/oracle/app/oracle/product/11.2.0/db/network/admin/listener.ora
Log messages written to /home/oracle/app/oracle/diag/tnslsnr/RallyOn-Pre-001/listener/alert/log.xml
Error listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=rallyonprem-oraclese.generic.com)(PORT=1521)(IP=FIRST)))
TNS-12545: Connect failed because target host or object does not exist
 TNS-12560: TNS:protocol adapter error
  TNS-00515: Connect failed because target host or object does not exist


Listener failed to start. See the error message(s) above...


 

Environment

Release:
Component: ACPREM

Cause

This is caused by the hosts file missing an entry for rallyonprem-oraclese.f4tech.com

Resolution

  1. ssh into the Agile Central on-premise appliance
  2. Log in as root
  3. Edit the /etc/hosts file
  4. Locate the line that begins with 127.0.0.1
  5. At the end of that line, add rallyonprem-oraclese.f4tech.com
  6. Save the file
  7. Issue the following command to start the Oracle database:


service dbora start

Additional Information

Requesting and updating the root password for the Agile Central on-premise appliance