EPAgent Error: "Can't load log handler"
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EPAgent Error: "Can't load log handler"

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Article ID: 108566

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Updated On:

Products

STARTER PACK-7 CA Rapid App Security CA API Gateway

Issue/Introduction

  • This error is observed in /opt/apmnnn/epagent/logs/IntroscopeEPA.log when the EPAgent starts:
7/23/18 01:16:00 PM EDT [INFO] [EPAgent.EPAgent OS_RESOURCE] Starting plugin 'OS_RESOURCE'.
7/23/18 01:16:00 PM EDT [INFO] [EPAgent.EPAgent OPERATING_STATUS] Starting plugin 'OPERATING_STATUS'.
7/23/18 01:16:01 PM EDT [ERROR] [EPAgent.EPAgent OPERATING_STATUS] [ stderr ] Can't load log handler "java.util.logging.FileHandler"
7/23/18 01:16:01 PM EDT [ERROR] [EPAgent.EPAgent OPERATING_STATUS] [ stderr ] java.nio.file.AccessDeniedException: logs/config.log.lck
7/23/18 01:16:01 PM EDT [ERROR] [EPAgent.EPAgent OPERATING_STATUS] [ stderr ] java.nio.file.AccessDeniedException: logs/config.log.lck

 

Environment

  • CA API Gateway 9.x with EPAgent for PAPIM 3.3.x installed on it.

Cause

  • Issue is caused by EPAgent not being able to update IntroscopeEPA.log, due to insufficient permissions on /opt/SecureSpan/Gateway/config/logs folder.

Resolution

  • Adjust permissions on /opt/SecureSpan/Gateway/config/logs folder, to give EPAgent sufficient the ability to write to  IntroscopeEPA.log, and restart the service.
# chmod 775 /opt/SecureSpan/Gateway/config/logs
# service epagent restart