UVC: Object and Job Runs not displayed, error 300
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UVC: Object and Job Runs not displayed, error 300

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Article ID: 108560

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Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

When attempting to access Job Runs or other menus in UniViewer the objects (Uprocs, Resources, Tasks etc.) of a specific Node are not displayed.
 A popup with the following error may appear:
Access denied error: 300

Note that in some cases no error is displayed but we get an empty window.

Another possible symptom is that the Node Settings of the node are not accessible either.

In some cases, some users with a particular Administrator Group can access the node, but some other belonging to a different Group cannot.

In this case this particular error may appear:

|ERROR||BackgroundWorker-x|com.orsyp.kmeleon.environment.ExceptionManager|An error occurred 
on ENVIRONMENT: (node = null environment = null) 
com.orsyp.UniverseException: IO Connection problem - Node's data is incorrect or not found. [COMPANY/Node/X]

Environment

Release: 6.x
Component: Dollar Universe

 

Cause

This issue happens when the UVC user has no correct permissions on the Node.
Several cases are possible:

1. The Dollar Universe administrator has not granted the appropriate rights to the user ( ie, missing Tag on the Node or missing Role on the Group)

See also this KB: Access denied or Permissions issues on DUAS Nodes recently added to Node View
 
2. There is a problem with the file u_fmsc60.dta that locally stores the security settings and is synchronized with UVMS.
When opening the file <DUAS>/data/u_fmsc60.dta, only a few lines are visible and the file does not look the same as for the rest of the nodes where the issue does not occur.
3. The node appears with status "Connected with warning" - this usually means that the engine SYN is stopped or that there is a firewall between the Node and the UVMS blocking the traffic.

Resolution

In order to resolve the issue follow the steps below one-by-one until the issue is resolved:

  • First, make sure that the engine SYN is started and if not start it with the command "uxstr fnc fnc=SYN"
  • Then check the User, its Node Views, its Groups and the Roles inside the Groups. To detect missing rights you can set the "Main log level" in the Node Settings to 0,SECURITY and perform the action in UVC and check the security messages in universe.log that indicate which rights are missing.
  • If the check above did not resolve the situation, try to do a Full Synchronization from UVC by double clicking on the node in the Node List followed by Full Synchronization ( note that in case there is a network issue, buttons will be greyed out). 
  • If this does not improve either, go directly to the server hosting the node and rename the file that governs the synchronization. This should trigger a Full Synchronization:
On Windows rename:  <DUAS>\data\u_sync.dta
On Linux/Unix rename: <DUAS>/data/u_sync.dta
 
Check in universe.log that the following lines appear:
 |INFO |X|IO |pid=p.t| io_sync_nodes             | Full sync of <K> nodes
 |INFO |X|IO |pid=p.t| io_sync_roles             | Full sync of <L> security roles
 |INFO |X|IO |pid=p.t| io_sync_groups            | Full sync of <M> security groups
 |INFO |X|IO |pid=p.t| io_sync_proxy             | Full sync of <N> proxy rules
 |INFO |X|IO |pid=p.t| io_sync_alert_rules       | Full sync of <O> alert rule

 
Sometimes it happens that the Full Sync is triggered but followed by an error in universe.log that mentions u_fmsc60.dta.
In that case stop the node and perform an offline reorganization to rebuild indexes.