Error: WSFEDSP Object 'Cannot be Saved' in XPSSweeper on Policy Server
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Error: WSFEDSP Object 'Cannot be Saved' in XPSSweeper on Policy Server

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Article ID: 108152

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On SITEMINDER

Issue/Introduction

 

Upon running XPSSweeper after upgrading a Policy Server from 12.52 SP1 to 12.7 SP2, the following error is observed:

(ERROR) : [sm-xobfss-00300] CA.SM::[email protected](sp_object_name): Legacy Federation object CA.SM::[email protected] cannot be saved; it conflicts with object CA.SM::[email protected] which is active

Users are not reporting any problems accessing applications.

 

Cause

 

Both of these objects have identical RPID values, but this value must be unique per Account Provider.  The first object in the list is the one that cannot be saved, and thus is the one that is not currently in use.

 

Resolution

 

Modifying the conflicting RPID of the object causing the error resolved the problem and allowed a clean XPSSweeper run.  The Admin UI can be used to make this change.

 

Additional Information

 

As the Policy Server and XPS Tools are continually being enhanced, newer versions of tools like XPSSweeper may be capable of detecting error conditions that previous releases did not find.