The CA Automic Windows Agent is not starting due to keystore is missing
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The CA Automic Windows Agent is not starting due to keystore is missing

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Article ID: 108120

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

The CA Automic Windows Agent is not starting due to keystore is missing. In the CA Automic Windows log, the following error message is present:

20180720/104500.975 - U02000073 Connection to system 'UC4P' via CP Server 'UC4P#CP002' successfully established.
20180720/104500.975 -           Get Key failed, reason: 'Value not initialized, 5003.'.
20180720/104500.990 - U00003359 Agent 'AgentName' uses an incorrect Company Key.
20180720/104500.990 - U02000041 Shutdown Agent 'AgentName'.


 

Environment

Products: CA Automic Windows Agent v11.x, v12.x
Operating System: All

Cause

When CA Automic Agents is started, it will connect to the CA Automic Automation Engine and it will create a key (UCXJWX6.kstr) as an identification to the Automation Engine. If this keystore is not present or is corrupted then the CA Automic Agent will not start. 

Resolution

There are two options to resolve this issue as explained below.

First Option:
The first option is to renew the keystore by transferring it from the Interface -> Administration -> Agents & Groups -> Agents -> Right click on the agent -> click on the Renew Transfer Key. Then restart the agent.






Second option:
If the first option does not work then please delete the UCXJWX6.kstr located in
the bin directory of the agent. Then restart the agent.