CABI 4.x Scheduled Reports with long report names fail
search cancel

CABI 4.x Scheduled Reports with long report names fail

book

Article ID: 108072

calendar_today

Updated On:

Products

SUPPORT AUTOMATION- SERVER CA Service Desk Manager - Unified Self Service CA Service Desk Manager CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Creating CABI 4.1 report schedules with instance names longer than 70 characters causes the schedules to fail with the following error message:

Could not open the file C:\Program Files (x86)\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\FileStore\Output\a_021\026\000\6677\012345678901234567890123456789012345678901234567890123456789012345678901_30_9126521297334807839-guid[afd91171-3616-4e8e-a942-f51e55b107fb1].xlsx.

Environment

CA Business Intelligence 4.x
All Supported Windows Operating Systems

Cause

Instance name length limitation/bug with CABI 4.x

Resolution

There are two (2) workarounds possible:

1.  Shorten the CABI instance report name
2.  Move the existing CABI File Store to a new location

A.  Stop SIA via the Central Configuration Manager
B.  Navigate to CABI Installation File Store directory.  By default the location is 'C:\Program Files (x86)\CA\SC\CommonReporting4\SAP BusinessObjects Enterprise XI 4.0\FileStore'
C.  Move the File Store folder to another location.
D.  Restart SIA via the Central Configuration Manager
E.  Login to the Central Management Console as the CABI Administrator
F.  Navigate to SERVERS->SERVERS LIST
G.  Select Input File Repository Server and Output File repository servers (InputFileRepository and OutputFileRepository), right-click and select PROPERTIES.
H.  Change the Default path (File Store Directory) to the new path of the File Store location from Step C above
I.  Restart the Servers by right-clicking on the servers and selecting RESTART SERVER