JCP forces trace during startup: java.lang.NoClassDefFoundError: javax.naming.ldap.LdapName

book

Article ID: 108046

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

When trying to bring up the JCP with SSL the following exception occurs during startup:
" U00045015 The previous error was caused by 'java.lang.ClassNotFoundException: "javax.naming.ldap.LdapName cannot be found by com.automic.rest_1.0.0"' at 'org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal():5"

Please find a detailed excerpt from the created force trace file below:
20180716/145345.407 - 103 U00045025 OSGI ['org.eclipse.equinox.ds']: '[SCR] Exception while activating instance [email protected] of component com.automic.rest.RestComponent ' 
20180716/145345.412 - 103 U00045014 Exception 'java.lang.reflect.InvocationTargetException: "null"' at 'sun.reflect.NativeMethodAccessorImpl.invoke0()'. 
20180716/145345.416 - 103 U00045015 The previous error was caused by 'java.lang.NoClassDefFoundError: "javax.naming.ldap.LdapName"' at 'org.eclipse.jetty.util.ssl.X509.<init>():97'. 
20180716/145345.417 - 103 U00045015 The previous error was caused by 'java.lang.ClassNotFoundException: "javax.naming.ldap.LdapName cannot be found by com.automic.rest_1.0.0"' at 'org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal():501'. 

20180716/145345.431 - 103 U00045025 OSGI ['org.eclipse.equinox.ds']: '[SCR] Exception while activating instance [email protected] of component com.automic.rest.RestComponent ' 
20180716/145345.436 - 103 U00045014 Exception 'java.lang.reflect.InvocationTargetException: "null"' at 'sun.reflect.NativeMethodAccessorImpl.invoke0()'. 
20180716/145345.437 - 103 U00045015 The previous error was caused by 'java.lang.NoClassDefFoundError: "javax.naming.ldap.LdapName"' at 'org.eclipse.jetty.util.ssl.X509.<init>():97'. 
20180716/145345.439 - 103 U00045015 The previous error was caused by 'java.lang.ClassNotFoundException: "javax.naming.ldap.LdapName cannot be found by com.automic.rest_1.0.0"' at 'org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal():5 


Please note that this issue only occurs when ssl is enabled
 

Cause

Bug in the java communication process (JCP)
 

Environment

N/A

Resolution

Update to a fixed version listed below or a newer version if available:
Automation Engine 12.2.0 HF1 - Available