Unable to connect to JasperSoft Server via JasperSoft Studio - errors "Server URL is invalid" / "Connection reset"

book

Article ID: 108033

calendar_today

Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Connection test for Data Adapter and JasperSoft Server through Studio fails with below exception:

Data Adapter connection test returns with an exception:
Reason: java.sql.SQLException: Server URL is invalid. Please check reporting server complete url in the JDBC URL.

Server Connection test returns socket exception:
faultString: java.net.SocketException: Connection reset 

Cause

Network Proxy restrictions are causing JasperSoft Studio connection failure with JasperSoft Server on SaaS.

Environment

Clarity SaaS Jaspersoft

Resolution

Engage your local network team to set up a Manual Proxy on JasperSoft Studio.

  1. Go to Windows > Preferences > General > Network Connections
  2. Change Active Provider to 'Manual' instead of 'Direct'.

NOTE: Alternatively, you can add it as 'Proxy Bypass Host' if your corporation Proxy allows this.

Additional Information

See also: Jaspersoft / reports known issues with Clarity