Unable to connect to JasperSoft Server via JasperSoft Studio
book
Article ID: 108033
calendar_today
Updated On:
Products
CLARITY PPM FOR ITGCLARITY PPM FEDERALClarity PPM SaaSClarity PPM On Premise
Issue/Introduction
Connection test for Data Adapter and JasperSoft Server through Studio fails with given exception:
Data Adapter connection test returns with an exception: Reason: java.sql.SQLException: Server URL is invalid. Please check reporting server complete url in the JDBC URL.
Server Connection test returns socket exception: faultString: java.net.SocketException: Connection reset
Cause
Network Proxy restrictions is causing JasperSoft Studio connection failure with JasperSoft Server on SaaS.
Environment
CA PPM SaaS
Resolution
Please engage local network team to setup Manual Proxy on JasperSoft Studio available under Windows > Preferences > General > Network Connections > Active Provider to 'Manual' instead of 'Direct'.
NOTE: Alternatively you add it as 'Proxy Bypass Host' and your corporation Proxy allows this.
Additional Information
Refer# Jaspersoft Studio Professional CA JDBC Adapter: https://docops.ca.com/ca-ppm-saas/15-4/en/advanced-reporting-with-jaspersoft/jaspersoft-studio-professional-ca-jdbc-adapter