After upgrading to Java 8 Update 181, the domain field is now null in the Enterprise Management GUI. Any login attempt results in an instant timeout error.
Cause
The issue is occurring because Java 8 Update 181 enables Endpoint Identification for LDAPS connections. In the release notes, Oracle says it could cause applications using LDAPS to no longer be able to connect.
Environment
Enterprise Management server configured for LDAPS connection Java 8 Update 181
Resolution
In order to restore the LDAPS connection with Enterprise Management, follow the steps below to disable Endpoint Identification.
On Linux: 1- Stop JBoss 2- Go to /opt/jboss-4.2.3.GA/bin and open run.sh with vi 3- In run.sh, search for one of the JAVA_OPTS lines and add the following # Disable Endpoint Identification, needed for Java 8 Update 181 and above JAVA_OPTS="$JAVA_OPTS -Dcom.sun.jndi.ldap.object.disableEndpointIdentification=true"
On Windows: 1- Open services and stop JBoss 2- Go to C:\jboss-4.2.3.GA\bin and open run.bat with notepad 3- In run.bat, search for one of the JAVA_OPTS lines and add the following lines rem Disable Endpoint Identification, needed for Java 8 Update 181 and above set JAVA_OPTS=%JAVA_OPTS% -Dcom.sun.jndi.ldap.object.disableEndpointIdentification=true
Additional Information
For more information regarding the change in Java 8 Update 181, please refer to Oracle's Release Notes (exact link subject to change). https://www.oracle.com/technetwork/java/javase/8u181-relnotes-4479407.html