Agent status not showing Active on dSeries
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Agent status not showing Active on dSeries

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Article ID: 107993

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Updated On:

Products

DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries) CA Workload Automation DE - Scheduler (dSeries) CA Workload Automation DE - Business Agents (dSeries) CA Workload Automation DE

Issue/Introduction

Agent installation completed successfully and it's communicating with dSeries scheduler but not 'active' in Topology.

Environment

Workload Automation DE r12.x
Workload Automation System Agent 

Cause

The Agent's encryption type/key does not match the one defined for the DE scheduler in the Topology. There are exceptions like below in agent's logs;

receiver.log
07/25/20xx 14:01:31.882-0500 1 TCP/IP Controller Plugin.Receiver pool thread <Regular:1>.CybReceiverChannel.a[:234] - cybermation.library.communications.CybConversationException: Unexpected encryption type. DES received. AES expected.

transmitter.log
07/25/20xx 13:38:27.097-0500 1 TCP/IP Controller Plugin.Transmitter pool thread <Regular:1>.CybTargetHandlerChannel.a[:628] - Error sending message to CENTRAL_MANAGER:
cybermation.library.communications.CybConversationException: Unexpected encryption type. DES received. AES expected.

Resolution

The Agent's encryption could be reset after installation using either option 1 or 2.

Option 1: Use the keygen utility in agent installation directory to reset the encryption on the Agent after agent installation;

  1. Stop Agent
  2. Change to the Agent installation directory.
  3. Enter the keygen command to specify the encryption method and key at the command prompt:
    For example;
    keygen 0x3132333435363738 DES
    Notes:
    - The encryption key should be prefix with 0x
    - The encryption key and type should match the one defined in Topology.
  4. Start Agent

Option 2: If the encryption key is the same across active agents, copy the cryptkey.txt file from a working and active agent to the installation directory of the inactive agent, and restart the agent. By default, the cryptkey.txt file is located in agent installation directory as set in agent's agentparm.txt file. For example;
security.cryptkey=<full_path_to_agent_directory>/cryptkey.txt

Option 3: If the Agent was installed as AE (Autosys) agent instead, uninstall and reinstall the Agent for other scheduler, for agent to work with DE (dSeries). Make sure to use a matching encryption with DE Scheduler.