Synchronize Agile Central job fails when the Milestone Name is more than 32 characters
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Synchronize Agile Central job fails when the Milestone Name is more than 32 characters

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Article ID: 107942

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

When running the agile central sync job in CA Clarity PPM, it fails at the step of creating a milestone. This is determined by reviewing the bg-ca.logs.

  • Tip: To check the bg-ca.logs, see KB: KB000113183 for steps on how to get the logs

The bg-ca.logs shows the following error:

Error message: [CA Clarity][Oracle JDBC Driver][Oracle]ORA-12899: value too large for column "SCHEMA"."INT_AGL_MILESTONES"."MILESTONE_NAME" (actual: 35, maximum: 32)

Further in the logs we see the input with the ID and name of the milestone:

{milestoneName=THIS_IS_A_VERY_LONG_MILESTONE_NAME_IN_CA_AGILE_CENTRAL, milestoneCode=MI12345, milestoneID=240628258060, id=240628258060}

Environment

CA Clarity PPM - Integrated with CA Agile Central/Rally

Clarity PPM 15.2 15.3, 15.4,15.4.1, 15.5

Cause

This is due the milestone length being shows us that there is a milestone which the name is longer than 32 characters, causing the failure.
 

Resolution

This is a known defect - DE42649, fixed in 15.5.1

Workaround: 

  1. Edit the milestone name in CA Agile Central to be less than 32 characters. 
  • While you can reference the error in the bg-ca.logs for one milestone causing the issue, there may be others that also need to be corrected. (See tips below on how to check for milestones)
  • Otherwise, the job will continue to fail until all milestones greater then 32 characters are shortened
  • In versions of Clarity prior to 15.5, all milestones whether associated to a project in Clarity or not, will need to be updated, as in 15.5 and lower, the job checks all milestones.

   Tips:

Tip 1: To pull a list of all milestone names to check for those > then 32 characters:

1. Click on the following link which will export all milestones in Rally to CSV: https://rally1.rallydev.com/slm/webservice/v2.0/milestones.csv?fetch=Name

Tip 2: To pull more detailed information for the milestones: 

Prerequisite: In order to see all milestones, admin permissions in Rally may be needed, some milestones impacting the job may not show up based on access

  1. In rally, go to the top project level and then go to Plan->Timeboxes
  2. Select 'Milestones' next to the Timeboxes drop down
  3. Click the Export/Print icon on the right hand side then select 'Export to CSV'
  4. Format the data so the milestone names show in one column and check for any > 32 characters

2. Rerun the Rally sync job

3. If it does still fail, check the bg-ca.logs to see if it's still failing with the same error related to a different milestone that may have been missed.

Additional Information

See KB 141061 - How to search for known Clarity PPM Issues using Self Service