DSM Reporter showing "Attempted an unsupported operation" error
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DSM Reporter showing "Attempted an unsupported operation" error

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Article ID: 107891

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Updated On:

Products

CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

When ends users try to modify or create a new report, the error "Attempted an unsupported operation." appears:

Environment

Client Automation 14.x

Cause

The problem is caused because DSM Reporter is installed on a remote Agent which has a language different than English configured (for example, Spanish).

Every management component (like DSM Explorer / Reporter) is not supported having Spanish language configured, the only supported languages are: English, French, German and Japanese. Here is the detail of the supported languages:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/clarity-client-automation/14-5/release-information/Release-Information-14-5/languages-support.html

Resolution

In order to solve this problem, the language of the Agent needs to be configured back to English (or any other supported language) running the following command:
ccnfcmda -cmd SetParameterValue -ps itrm/common/localization -pn language -v lang

The value of lang specifies the desired language. Possible values are "enu" (English (U.S.)), "deu" (German), "fra" (French), and "jpn" (Japanese).