Problem during upgrade from 14.1 to 17.1 on product integration phase
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Problem during upgrade from 14.1 to 17.1 on product integration phase

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Article ID: 107875

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Customer is trying to upgrade Service Desk Manager from 14.1 to 17.1 and is getting some messages in the Integration phase:

2018/07/08 01.48.39.911 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] OSOP_SDM_IS_INTEGRATED : false OSOP_HOSTNAME (USS_SERVER_HOSTNAME) SDM_HOSTNAME (USS_SERVER_HOSTNAME) isOSOPIntegSkipEnabled :(true)
2018/07/08 01.48.39.912 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Validating OSOP User Login (CASMAdmin) URL: (http://USS_SERVER_HOSTNAME:8686/rest/session) 
2018/07/08 01.48.39.961 ERROR [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Unable to login into Unified Self-Service on server: USS_SERVER_HOSTNAME
2018/07/08 01.48.39.962 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Not Found 
2018/07/08 01.48.39.972 ERROR [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Unable get CA Service Desk Manager configuration details on Unified Self-Service on server: USS_SERVER_HOSTNAME
2018/07/08 01.48.39.972 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Not Found 
2018/07/08 01.48.39.972 INFO [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Was Unified Self-Service integrated with CA Service Desk Manager earlier : false 
2018/07/08 01.48.39.972 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSDM] Execution of integration task (com.ca.smsi.installui.integration.tasks.ConfigureOSOPWithSDM) is false 
2018/07/08 01.48.39.972 DEBUG [DeployThread: Integrating the Product(s)] [AutoIntegrateTask] Executing auto-integration task : Class <com.ca.smsi.installui.integration.tasks.ConfigureOSOPWithSDM> . Integration isAllowed : false 
2018/07/08 01.48.39.995 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] OSOP_SLCM_IS_INTEGRATED : false SLCM_HOSTNAME (SLCM_SERVER_HOSTNAME) osopHostname :(USS_SERVER_HOSTNAME) isOSOPIntegSkipEnabled :(true) 
2018/07/08 01.48.39.995 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Validating OSOP User Login (CASMAdmin) URL: (http://USS_SERVER_HOSTNAME:8686/rest/session) 
2018/07/08 01.48.40.042 ERROR [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Unable to login into Unified Self-Service on server: USS_SERVER_HOSTNAME
2018/07/08 01.48.40.042 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Not Found 
2018/07/08 01.48.40.055 ERROR [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Unable get CA Service Catalog configuration details on Unified Self-Service on server: USS_SERVER_HOSTNAME
2018/07/08 01.48.40.056 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Not Found 
2018/07/08 01.48.40.056 INFO [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Was Unified Self-Service integrated with CA Service Catalog earlier : false 
2018/07/08 01.48.40.056 DEBUG [DeployThread: Integrating the Product(s)] [ConfigureOSOPWithSLCM] Execution of integration task (com.ca.smsi.installui.integration.tasks.ConfigureOSOPWithSLCM) is false 

Even after prforming the procedure from KB Article below, the problem persisted:
Problem with Integration Step USS in Migration

 

Environment

CA Service Desk Manager 17.1

Cause

Some references in AL_CDB_CONFIGURATIONPARAMETERS from previous installations are affecting the upgrade and should be removed

Resolution

Custome manually removed all the rows from AL_CDB_CONFIGURATIONPARAMETERS table with the fiter: configkey like 'osop.%'
After that, he ran the migration to 17.1 again and it worked well.

Additional Information

Problem with Integration Step USS in Migration