"IP n.n.n.n is not in address table returned - removing it from the discovered list" seen in Spectrum discovery console
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"IP n.n.n.n is not in address table returned - removing it from the discovered list" seen in Spectrum discovery console

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Article ID: 107719

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Updated On:

Products

CA Spectrum

Issue/Introduction

When running a Spectrum AutoDiscovery, the following message is seen in the Discovery Status window:

IP n.n.n.n is not in address table returned - removing it from the discovered list

What does this message mean?

Environment

Any Spectrum version

Cause

When SPECTRUM discovers a device, it checks to verify the ip address used to communicate with the device is a valid ip address for that device by reading the ipAddrTable. If the ip address is not in the ipAddrTable, then AutoDiscovery will display the "IP n.n.n.n is not in address table returned - removing it from the discovered list" message and remove the ip address from the discovered list.

Resolution

The reason for the check is to verify the device that is responding is the correct device.

Reasons why the ip address is not in the ipAddrtable are as follows:

1. It's a NAT IP

2. It's a subnet address, not device address.  For example, for subnet 10.253.9.128/25, 10.253.9.128 is the subnet ID, not a device IP.  However, we have seen where the router that routes to that subnet could respond to an SNMP query at 10.253.9.128

3. A device does not support or has a bug in the standard IP MIB (ipAddrTable)

Additional Information

NOTE: You can tell the AutoDiscovery process to ignore this message by clicking on the "Advanced Options..." button in the Configuration tab and unchecking the "Required discovery IP Entry in the device;s IP Address Table" check box.