Symantec Identity Manager - lock12_5 table grows large and/or causes locking contention
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Symantec Identity Manager - lock12_5 table grows large and/or causes locking contention

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Article ID: 10771

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Updated On:

Products

CA Identity Manager CA Identity Governance CA Identity Portal CA Identity Suite

Issue/Introduction

The lock12_5 table is one the Task Persistence tables in the IDM object store. It's used to lock events in progress while the environment is up and running but it does not automatically delete its table entries after events are updated, therefore the table can grow to host millions of rows and cause system slowness or database session locking or other DB errors.

 

Environment

All versions of Identity Manager

Cause

lock12_5 table does get cleaned up by the cleanup stored procedures or by the Cleanup Submitted Tasks task. It is common to see leftovers in this table even when cleanup is regularly scheduled on your environment.

The table should be cleaned up regularly by your DBA and should be purged if you are seeing any DB errors, contention, or locked sessions against task12_5.

The lock12_5 table should be purged only while the environment is not running so as not to delete active locks. As long as the environment is not running, there is no possibility of transaction loss or data integrity issues when all rows are deleted.

Resolution

To clean up the lock12_5 table:

1. Stop the Identity Manager application on all nodes (or at least stop all IMEs on all nodes).

2. On the task persistence database, kill any locks or active sessions to the lock12_5 table, if any exist.

3. Drop all rows within the lock12_5 table using the below query:

TRUNCATE TABLE lock12_5 ;

4. Start the Identity Manager application.