System Agent 11.3 SP7 on HP Nonstop requires Java 1.7, does not support 1.8

book

Article ID: 107640

calendar_today

Updated On:

Products

CA Workload Automation AE - Business Agents (AutoSys) CA Workload Automation AE - Scheduler (AutoSys) CA Workload Automation Agent

Issue/Introduction

System Agent 11.3 SP7 Install fails on a Tandem HP Nonstop system with the following messages in the Install Log:

Custom Action:            cybermation.iainstaller.library.nonstop.CybNonStopJREVersionCheck
                           Status: SUCCESSFUL

Custom Action:            cybermation.iainstaller.library.CybFatalException
                          Status: FATAL ERROR
                          Additional Notes: FATAL ERROR -     class cybermation.
iainstaller.library.CybFatalException FatalInstallException: Selected JRE is invalid.  JRE version 1.7  is required



 

Cause

This version of the Agent for this environment requires Java 1.7, and the site was running Java 1.8. ( Not all Agent environments were tested with Java 1.8)
The System Agent documentation states : https://docops.ca.com/ca-workload-automation-system-agent/11-3/en/release-notes/system-requirements-and-supported-platforms/minimum-recommended-hardware-and-software-requirements-by-agent-version

Section: (System Agent 11.3)

Minimum Recommended Hardware and Software Requirements by Agent Version

 
HP Integrity NonStop Itanium 64-bit300 MB500 MBNot shipped. See "Notes."The JRE is not supplied with the agent. The agent was tested with JRE 1.7 update 25.

 

Environment

New Agent Install on a Tandem HP Nonstop system

Resolution

The recommendation is to install the System Agent 11.4 which will support Java 1.8.
 
Section: (System Agent 11.4)

Minimum Recommended Hardware and Software Requirements by Agent Version

HPE Integrity NonStop Itanium 64-bit300 MB500 MBNot shipped. See "Notes."The JRE is not supplied with the agent. The agent was tested with JRE 1.7 update 25 and JRE 1.8 update 45.