Single Sign On does not work on Jasper Server when using LDAP in CA Spectrum
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Article ID: 107549
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Updated On:
Products
CA Spectrum
Issue/Introduction
Single Sign On does not work on Jasper Server when using LDAP in CA Spectrum
Environment
CA - Spectrum = 10.X Jasper server = 6.3.0, 6.4.2 or 6.4.3 Operating System = Linux
Cause
When Single Sign On is enabled in Jasper Server and at the same time if you enable the Single Sign On feature in CA Spectrum, you may face access issue for Jasper SSO and using LDAP in Spectrum.
Jasper SSO - Enabled + Saved CA Spectrum SSO - Enabled CA Spectrum - LDAP
Resolution
1) In the CA OneClick Spectrum machine, go to $Specroot\tomcat\webapps\spectrum\repmgr\admin folder.
2) Copy the 'spectrum.jks' and 'spectrum.properties' files.
3) In the Jasper machine, go to <<CABusinessIntelligenceINstalledDIR>>\apache-tomcat\webapps\jasperserver-pro\WEB-INF\config folder.
4) Replace the existing 'spectrum.jks' and 'spectrum.properties' files with the copied files from CA OneClick Spectrum machine.
On the Jasper server:
1.Stop tomcat and copy applicationContext-externalAuth-template-mt.xml file from cabi-media (cabi-media\samples) folder to Tomcat/webapps/jasperser-pro/WEB-INF/ folder.
2.Make sure no backup file in entire webapps/jasperserver-pro folder(ex: like application-context.xml_bak),no duplicate file for any file in WEB-INF folder.
3.From the following bean remove the "highlited/ commented" portion in applicationContext-externalAuth-template-mt.xml after copying the file to Tomcat/webapps/jasperser-pro/WEB-INF/ folder.