Unable to find PKI libraries returned by Migration Wizard migrate_to_r17_0

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Article ID: 107486

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

I ran the CA Service Desk Manager Migration Wizard ( $NX_ROOT\bin\migrate_to_r17_0.vbs ) but received the error message, "Unable to find PKI libraries".

 

Cause

The registry does not contain HKEY_LOCAL_MACHINE > SOFTWARE > ComputerAssociates > Shared > CAPKI.

Instead it contains HKEY_LOCAL_MACHINE > SOFTWARE > ComputerAssociates > Shared > CAPKI5.

The issue may occur when EEM has not been installed.

Defect Reference: DE42676

      

Environment

CA Service Desk Manager 17.1 without EEM installed from DVD500000000001054.iso
 

Resolution

Work around:
  1. Change the $path value in "$NX_ROOT\bin\migrate_to_r17_0.pl" to point to HKEY_LOCAL_MACHINE > SOFTWARE > ComputerAssociates > Shared > CAPKI5 in the registry.
  2. Ensure that the InstallDir in the "HKEY_LOCAL_MACHINE > SOFTWARE > ComputerAssociates > Shared > CAPKI5 "registry entry is "C:\Program Files (x86)\CA\SC\eTPKI\CAPKI" and not "C:\Program Files (x86)\CA\SC\CAPKI" .

Note: 
For the CAPKI entry, the InstallDir would be "C:\Program Files (x86)\CA\SC\CAPKI".
For the CAPKI5 entry, the InstallDir would be "C:\Program Files (x86)\CA\SC\eTPKI\CAPKI".

Additional Information