"No Model Found" error or Unknown model when trying to delete a model in Spectrum OneClick
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"No Model Found" error or Unknown model when trying to delete a model in Spectrum OneClick

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Article ID: 107478

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Updated On:

Products

CA Spectrum

Issue/Introduction

"No Model Found" error when trying to delete a model in Spectrum OneClick

When trying to delete a model in OneClick, you may receive a "No Model Found" error message even though you can see the model in OneClick. Occasionally, you may also see an "Unknown" model in OneClick as well, as shown below:

Environment

Release: Any
Component: SPCOCK

Cause

The reason for both of these scenarios is that the models have already been deleted from the SpectroSERVER database. This can be validated by logging on to the SpectroSERVER and using the Command Line Interface (CLI) using the following command where <MODEL_HANDLE> is the Model Handle of the model you are trying to delete:

./show models | grep <MODEL_HANDLE>

If the model has already been deleted, you will not get any results.

This happens most often if the Spectrum Destroy queue has not finished processing the deleted models. If many models were deleting in bulk, the Destroy queue may be taking time to process, and the model you are trying to rediscover has not been processed yet.

You can wait some time, or you can force the Destroy Queue to process by restarting the SpectroSERVER.

If waiting, or restarting the SpectroSERVER does not solve the issue, then the next likely root cause would be the models are stuck in the OneClick "cache". This may happen most often after deleting many models in bulk or reloading a previously saved database on the SpectroSERVER system.

Resolution

To resolve this issue:

1. If the model was recently destroyed, you may just give some time before re-discovering. 

2. You can restart the SpectroSERVER to force Spectrum to process the Destroy queue. 

If the above does not solve the issue, then look at Tomcat for the next option: 

1.  Close any open OneClick clients

2.  Stop the Tomcat service on the OneClick server

3.  Delete the $SPECROOT/tomcat/work folder (this is essentially the tomcat cache folder)

4.  Restart the Tomcat service

5.  Launch back into OneClick and the "Unknown" entry will no longer be present.