Install/Upgrade failure of sql_check_db during Migrating CA Service Desk Manager step of the Installer
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Install/Upgrade failure of sql_check_db during Migrating CA Service Desk Manager step of the Installer

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Article ID: 107451

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Updated On:

Products

CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

While running upgrading CA Service Desk Manager from 12.9 to 17.1:

1. "Migrating CA Service Desk Manager Step" of the CA Service Management Installation fails
2. The following messages are written to the "pdm_migration17_0.log":

Migration Task Completed: do_file_verification
Verifying We Can Access Database...
 >> Running Cmd ("C:\PROGRA~2\CA\SERVIC~1\bin\sql_check_db.exe" -c 2>&1 |) 
 >> ERROR: AHD50072:Unable to log in to SQL Server 
 >> Cmd RC(99) 
EXITING . . .



 

Environment

CA Service Desk Manager 17.1
SQL Server : the mdb database is associated with a non-default instance and non-default port

Cause

When the SQL Server DBMS is remote and the instance is a named instance and the port is a non-default port, then despite providing the correct values to the installer in the Database Configuration form, the installer does not seem to use those values when running sql_check_db.  Instead, it seems to use the values from the NX.env file.

The Database Configuration form includes these fields:
Database Server: 
Database Name: 
Database Port: 
Database Server Instance:

And the NX.env file contains the corresponding environment variables:
@NX_DB_TYPE=SQL
@NX_DB_NODE=<servername>
@NX_DB_PORT=<port>
@NX_DB_STUFF=mdb
@NX_DB_USERID=mdbadmin
@NX_DB_INSTANCE=NX_DB_INSTANCE_REPLACE

 

Resolution

The issue has been reported as Defect DE42672. 

Here is a possible work-around that has been used successfully:

1. On the CA SDM server, edit NX.env and set NX_DB_NODE to the following format:



<dbms_hostname>\\<named_instance>,<correct_port> 

For example:
@NX_DB_NODE=sdmsqldb001\\test,61349
 
2. On the CA SDM server, run a preliminary test by running "sql_check_db -c" from a command line prompt. 
Confirm the results before continuing to step #3.

The results should be: 



SUCCESS - pri table exists, and has 6 rows 
DB_OK 



3. Run the installer. In the Database Configuration form, enter the corresponding correct parameter values:

For example:
Database Server: sdmsqldb001
Database Name: mdb 
Database Port: 61349
Database Server Instance: test



Confirm that the "Migrating CA Service Desk Manager" step completes successfully.

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