PAM upgrade from 3.0.2 to 3.1.1 failed with "PAM-CMN-1264: Upgrade failed. Please review the audit log and then perform a system recovery" error message
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Article ID: 106957
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Updated On:
Products
CA Privileged Access Manager - Cloakware Password Authority (PA)PAM SAFENET LUNA HSMCA Privileged Access Manager (PAM)
Issue/Introduction
We attempted to upgrade PAM 3.0.2 to 3.1.1, but it failed. After reboot the following upgrade error message was observed:
PAM-CMN-1264: Upgrade failed. Please review the audit log and then perform a system recovery.
Cause
The most likely cause is a known bug related to a failure of altering a database table during the upgrade. Whether or not a PAM instance is affected depends on the upgrade history and configuration. If logs.bin file is collected CA Technical Support can find the following error in the installation log.
-------------- ALTER TABLE `uag`.`kdc_server` DROP FOREIGN KEY `kdc_server_ibfk_1` --------------
Mysql schema update of file 3.1.0_upgrade.sql failed 1, we're going to abort
Environment
PAM 3.0.2
Resolution
The CAPAM_3.0.2.17 hotfix resolves this issue. Please go to
and download CAPAM_3.0.2.17 hotfix. Apply this hotfix first, and then retry the upgrade to 3.1.1.
NOTE: There has been at least one case in which the upgrade to 3.1.1 still failed after applying the hotfix. If you encounter this problem, please open a support case with CA support.