Unable to get a device to assign High Speed Interface
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Unable to get a device to assign High Speed Interface

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Article ID: 106916

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration

Issue/Introduction

Despite having all required OIDs, a device is not discovering based off of the ifXTable

Environment

All supported releases

Cause

The device is not responding to either get or get next queries when the device is being discovered.

using DCDEBUG ( http://daHostname:8581/dcdebug/searchdebug.html ) begin collecting Detailed SNMP Logging by IP and then kick off another discovery attempt.

In the logging you can see entries of each SNMP request made such as: 

Jun 11 10:03:55.423: received MIB discovery response for 1.3.6.1.2.1.10.94.1.1.4.1.2 - next oid 1.3.6.1.6.3.1.1.6.1.0

What this tells us is that PM asked the device for the OID that comes after 1.3.6.1.2.1.10.94.1.1.4.1.2 and the device responded with 1.3.6.1.6.3.1.1.6.1.0.  The ifXTable (which houses the OIDs required for the High Speed Interface Vendor Cert) is 1.3.6.1.2.1.31.1.1.  In this example, the device reported the table as not existing despite the fact that the table is directly able to be queried by snmp get commands.

Resolution

This is a defect in the device / firmware.  Please take the information gathered in the SNMP logging and reach out to the device manufacturer for further device specific troubleshooting.