Client Automation - Disable Post Registration AM Agent execution
search cancel

Client Automation - Disable Post Registration AM Agent execution

book

Article ID: 106899

calendar_today

Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

After execution of caf register command, AM Agent is automatically executed. If a lot of caf register are done every day, this could generate several execution of AM Agent and generates lot of inventory files to be collected on sector.

In this article is explained how to disable the execution of AM Agent after caf register command.

Environment

Client Automation - All Versions

Cause

By default caf register command is automatically executed at these times :


- At startup of caf service

- At startup of caf service + a random delay of 90 minutes (scheduled task "Registration refresh scheduled job")

- at 12pm + a random delay of 90 minutes (scheduled task "Registration refresh scheduled job")

- when caf detects a modification in ipaddress list of the machine. (example : if machine switches from Wifi network to cable network).



This could generate a lot of executions of "caf register" per day and lot of executions of AM Agent.

AM Agent is also executed every day at 1am + a random delay of 90 minutes (scheduled task "Run the UAM agent")

Resolution

Following command could be executed on the agents in order to remove the execution of amagent plugin at the end of "caf register" process :

ccnfcmda -cmd SetParameterValue -ps itrm/agent/solutions/uam -pn postregistrationplugin -v ""

This command could be executed on all machines using a SD Package or a AM job of type Command.


Example for AM Job :
 

  • Create a new Asset Jobs of type “Command”:



  • Give a name to the job. Ex: Remove amagent postregistrationplugin

 
  • In command textbox put this line:
ccnfcmda -cmd SetParameterValue -ps itrm/agent/solutions/uam -pn postregistrationplugin -v ""

  • In Scheduling options, put “Run only once”:


  
                And make sure that “This job is allowed to run unattended” is checked under Miscellaneous tab
  
 



  • Then assign this job to all machines
With these settings, AM Agent will be executed only at 1am. If machine is switched off at this time, AM Agent will not be executed during the day.
 
So scheduled task "Run the UAM agent" should be updated :
 
  • In ITCM Console, go under Control Panel/Configuration/Configuration Policy.

Unseal the “Default Computer Policy” or create/update a policy applied on all machines.

  • Then go under

DSM/Common Components/CAF/Scheduler/Run the UAM agent

And update these parameters:

CAF Scheduler: Hour = 12
CAF Scheduler: Random now time = 5400
CAF Scheduler: Type of job = now day random

 



With these settings, AM Agent will be automatically executed:
 
  • At startup of CAF service with a random delay of 90 minutes.
  • At 12pm with a random delay of 90 minutes.