Upgrading CA Performance Management from 3.5 to 3.6, DR not strarted

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Article ID: 106853

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Updated On:

Products

CA Infrastructure Management CA Infrastructure Management CA Performance Management - Usage and Administration CA Performance Management - Data Polling

Issue/Introduction

During or after upgrading CAPM from 3.5 to 3.6 DR not starting  by the command /dr_install.sh -p drinstall.properties 
 
It's redirecting to the Old IP instead of New one. 
YYY.YYY.YYY.YYY – New IP 
XXX.XXX.XXX.XXX – Old IP 
 
- Now the problem is that  not even able to start the VerticaDB: 
*** Starting database: DRDatabase *** 
Could not login with SSH to host  XXX.XXX.XXX.XXX 
 
The cluster is partitioned with XXX.XXX.XXX.XXX down. Over half (1/1) of the nodes must be available. 
Database start up failed. Cluster partitioned. 
Press RETURN to continue
 
Database DRDatabase did not start successfully: Cluster partitioned.

Cause

Checking the admintools.log, it's found that when starting the database, it tried to SSH to the wrong IPaddress(XXX.XXX.XXX.XXX) instead of the correct one(YYY.YYY.YYY.YYY) and reported database start up failed error.
Checking the IP address configuration in admintools.conf/spread.conf/catalog and found that the ip address in admintools.conf and spread.conf are both correct while the IP address in database catalog are incorrected as shown below.
45035996273704980      0            v_drdatabase_node0001            0              XXX.XXX.XXX.XXX             ipv4       0 …….

Environment

It is happened during upgrading CA PM from 3.5 to 3.6.

Resolution

1) Manually changing the ip address in admintools.conf and spread.conf same with the IP address in database catalog(the wrong IP address.
2) Prepare the re_ip configuration file named reip in folder /tmp:
     XXX.XXX.XXX.XXX YYY.YYY.YYY.YYY
3) Mapping the new IP(correct IP) with admintools
     admintools -t re_ip -f reip
4) Start the Vertica DB with admintools.
The database startup successfully, after checking the version, the Vertica DB working on 9.0.1 normally.  Verify to restart the Vertica DB for verification.