SUPPORT AUTOMATION- SERVERCA Service Desk Manager - Unified Self ServiceKNOWLEDGE TOOLSCA Service Management - Asset Portfolio ManagementCA Service Management - Service Desk Manager
Issue/Introduction
When using an AA environment, one may find from the app server that customisations from BG Server are not coming over, and that attachments may not upload either if the repository is situated on the BG Server.
Cause
Such a scenario may manifest if the App server does not show any of the following processes originating from the BG Server from an "slstat" command run:
Alternatively the App Server stdlog logging may also mention problems with the above processes connecting.
Environment
Release: Component: USRD
Resolution
Examine the network settings, if the firewall has sufficient open ports and that TCP and UDP are being allowed.
One may also wish to check if virus protection is compromising communication, or if any ports reserved for use by SDM are conflicting with another application.
UDP should also be configured on the network to allow access across subnets. This is of particular concern for environments in which the BG and App servers are found to be on different subnets. UDP does NOT necessarily transfer correctly across subnets.
Additional Information
Related Reading:
Why UDP is necessary for SDM communications: https://comm.support.ca.com/kb/why-is-it-necessary-to-have-open-the-udp-ports-2100-through-2200-and-port-2300-for-a-service-desk-installation-in-advance-availability/kb000041031
Limiting Port Bindings in CA Service Desk https://comm.support.ca.com/kb/how-to-limit-sdm-port-bindings/kb000045970
Required Firewall Ports in CA Service Desk https://docops.ca.com/ca-service-management/14-1/en/implementing/implementing-ca-service-management-14-1/step-4-install-or-upgrade/implementing-ca-service-desk-manager/how-to-install-ca-sdm/step-6-verify-the-installation/check-the-status-of-the-required-ports