Object Link for Service in an action item is not working
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Object Link for Service in an action item is not working

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Article ID: 106359

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

If an action item within a process is created with a link to the Service Object; the following error occurs when clicking on the link:

“[en - Unable to process request. Server or Network error]”


STEPS TO REPRODUCE

1. Create a process with the Object Type: Service
2. Click on the Steps tab
3. Click the New Step button to create a step
4. Fill in the Step Name and Step ID (other fields could be left as blank)
5. In the Step Details under Actions, click on the New button
6. Select the Action Type: Manual Action
7. Fill in the Action Name, Action ID, Subject and Assignees(to yourself)
8. In Actions click on Done from Available actions and bring it over to Selected
9. Click on the Save Button to return to the Step Details
10. In Post-conditions choose the Spit Type: Serial and click on [Build Conditions] under Then Go To
11. Select Finish
12. Click on the Save and Return to return to Process: Steps
13. Click on the Start Step tab
14. In Post-conditions choose the Spit Type: Serial and click on [Build Conditions] under Then Go To
15. Select the Action Item created in Step 3
16. Validate and Activate the process
17. Initiate the process by navigating to Services
18. Click on the New button
19. Fill in the Service Name and Service ID
20. Click on the Save button
21. Click on the Processes tab dropdown and choose Available
22. Click on the checkbox next to the Process created
23. Click on the Start button
24. Navigate to Organizer, under the Home Menu
25. Click on the Action Items tab
26. Click on the Action Item with name created in the Process
27. Under Object Links, click on the link next to Objects
 

Environment

Version 15.3.x only

Cause

This is caused by a defect that does not occur in 15.4 and above:  DE41989

 

Resolution

Defect is no longer occurring in 15.4 and above

WORKAROUNDS:

1. Copy the link from the Action item, remove one of the id parameters from the link (i.e. &id=5001074), paste in the new link and click ENTER. 

2. Create a gel script email notification to use instead of generating the action item withe Manual Action option in the process.