Client Automation - DSM GUI takes long time to display the homepage of a computer

book

Article ID: 106355

calendar_today

Updated On:

Products

CA Automation Suite for Data Centers - Configuration Automation CA Client Automation - Asset Management CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Remote Control CA Client Automation - Asset Intelligence CA Client Automation - Desktop Migration Manager CA Client Automation - Patch Manager

Issue/Introduction

DSM GUI hangs during 45 seconds when clicking on a computer under "All  Computers" folder.

This problem occurs only for the first computer. If another computer is selected, the homepage is displayed quickly.

 

Cause

When we click on a computer, the list of Failed jobs (and modules) is retrieved and displayed on the homepage of the computer under the Status box :
 

<Please see attached file for image>

User-added image


During the retrieving job status process, GUI is sending a message to plugin amms (Asset Management usage server (amms)) of the first Scalability Server by alphabetic order.

To determine which scalability server is used, go under Control Panel/Scalability Servers/All Scalability Servers.
Click on Name column to order it by name. 

In this example, the first scalability server by alphabetic order is JY_PC5 :
 

<Please see attached file for image>

User-added image


In logs DSM\logs\TRC_AMMETERAPI_*.log, we could see this :
 
Metering A|CFSMCAPI        |CFSMCAPI            |000000|NOTIFY | SMEVENT : New Session. Target = (JY-PC5) 192.168.188.167\CA_ITRM_METER. LID = 16640003. SH = 064e8ad8


If first scalability server is not available, not reachable or plugin amms is not running, there is a delay of 45 seconds due to the timeout.

 

Environment

Release: UASMGT60000-1402-Asset Management
Component:

Resolution

2 possibles solutions :


1- Check why the first scalability server is not available or reachable.
 
If this scalability server does not exist anymore, delete it under Control Panel/Scalability Servers/All Scalability Servers

Check with "caf status" if plugin amms is up and running. Start the plugin if it is not running :
caf status amms
caf start amms


If the scalability server is temporary not on network/reachable but it should not be deleted from ITCM, we could rename it in database to not have it on the top of scalability server list.


In Microsoft SQL Server Management Studio, execute a SQL Query like this :
UPDATE ca_server SET label='ZZ_SSNAME' WHERE label='SSNAME'

Example : UPDATE ca_server SET label='ZZ_JY_PC5' WHERE label='JY_PC5'


Later it is possible to give it the correct name with a query like :
UPDATE ca_server SET label='SSNAME' WHERE label='ZZ_SSNAME'

Example : UPDATE ca_server SET label='JY_PC5' WHERE label='ZZ_JY_PC5'


<Please see attached file for image>

User-added image
 
 




2- Other solution is to remove the option "List Erroneous Collect Modules" in Status box of computer homepage :

- Click on a computer.
- On the homepage, click on the small icon on top right of status box.

<Please see attached file for image>

User-added image


- Unselect the option "List Erroneous Collect Modules" :

<Please see attached file for image>

User-added image


- Click again on the small icon on top right of status box to leave the edit mode.


Remark :
 
This settings in stored in HKEY_CURRENT_USER registry key on the machine with DSM Explorer.
So this should be repeated for every remote console and for different logged users.

 

Attachments

1558693535589000106355_sktwi1f5rjvs16hco.jpeg get_app
1558693533757000106355_sktwi1f5rjvs16hcn.jpeg get_app
1558693532126000106355_sktwi1f5rjvs16hcm.jpeg get_app
1558693530133000106355_sktwi1f5rjvs16hcl.jpeg get_app
1558693528276000106355_sktwi1f5rjvs16hck.jpeg get_app