14.1 install error: Invalid Process Automation Details

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Article ID: 106343

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Updated On:

Products

CA Service Catalog CA Service Management - Asset Portfolio Management CA Service Management - Service Desk Manager

Issue/Introduction

Error "Invalid Process Automation Details" while installing Service catalog 14.1

Cause

The problem is that the installer is trying to connect to a HTTPS link for Process Automation and does not have the certificate available.

Environment

Release:
Component: USVCT

Resolution

We saw the error in the log:
C:\Users\Administrator\AppData\Local\Temp\2\casm\install.log
"unable to find valid certification path to requested target"
It was solved by:

a) As in your screenshot navigate to PAM via the browser and select 'Certificate' next to the URL 
b) Select 'View certificates' 
c) From the 'General' tab select 'Install Certificate...' 
d) Select 'Next' through the wizard 
2) Export the certificate: 
a) As in your screenshot navigate to PAM via the browser and select 'Certificate' next to the URL 
b) Select 'View certificates' 
c) From the 'Details' tab select 'Copy to File...' 
d) Select 'Base-64 encoded X.509 (.CER)' for the format 
e) Specify a file name (i.e. c:\pamcert) 
3) Import the certificate into the Catalog 14.1 install media (copied local to the server, not just mounted) JVMs trusted certificate store: 
a) Copy the certificate exported in step 2 to the Catalog server (i.e. c:\pamcert.cer) 
b) Open a command prompt (right-click and 'Run as Administrator') 
c) Change directory into <Catalog 14.1 install media>\java\jre 
d) Run the following: 
keytool.exe -import -noprompt -trustcacerts -alias pamcert -file c:\itpam.cer -keystore ..\lib\security\cacerts -storepass changeit 

The expected output of this command is as follows: 

Certificate was added to keystore