Recurring Connectivity Issues Between Domain Manager and Scalability Servers
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Article ID: 106289
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Updated On:
Products
CA Automation Suite for Data Centers - Configuration AutomationCA Client Automation - Asset ManagementCA Client Automation - IT Client ManagerCA Client AutomationCA Client Automation - Remote ControlCA Client Automation - Asset IntelligenceCA Client Automation - Desktop Migration ManagerCA Client Automation - Patch Manager
Issue/Introduction
CAM communication, camping, caf ping, failures and CAM clients (SS machines) switch from UDP to TCP on their own without cause. Problem gets worse after they switch to TCP
Environment
Any supported ITCA / ITCM CA Client Automation environment
Cause
When a system contains the following registry key, then any other machines that talk to it from IP Subnets that match the ENC default subnet range (172.27.0.1 to 172.29.0.1), and possibly others, will switch to TCP, thinking the clients are ENC agents, even when ENC is not enabled on the machine:
In the case recorded, this key only existed on the Domain Manager and ENC was disabled on all systems. Likewise the port multiplexor was not configured with ENC Enabled at all.
Solution
Deleting this registry key and rebooting, followed by a procedure like the following, allowed all SS systems to switch use UDP and no longer switch to TCP and start having communication failures:
Set MyError=0 tasklist | findstr /i /c:cam.exe Set MyError=%errorlevel% If %MyError%==0 taskkill /f /im cam.exe
cam stop
Set MyError=0 tasklist | findstr /i /c:csampmux.exe Set MyError=%errorlevel% If %MyError%==1 goto :skippmux
csampmux stop
:skippmux
Set MyError=0 tasklist | findstr /i /c:csampmux.exe Set MyError=%errorlevel% If %MyError%==0 taskkill /f /im csampmux.exe
<perform corrective actions on all SS machines involved>*
CAM change auto & CAM start -c -l
Set MyError=0 tasklist | findstr /i /c:csampmux.exe Set MyError=%errorlevel% If %MyError%==1 csampmux start
CAF Start
*Corrective actions can be simplified down to simply rebooting the SS or client machines after making sure there are no items in the *PATHS section of CAM.CFG (if it exists) in %cai_msq% that attempt to force communication to the target machine, in this case, the Domain Manager.