Error assigning a role to a search in ITAM
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Error assigning a role to a search in ITAM

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Article ID: 106201

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Updated On:

Products

CA IT Asset Manager CA Service Management - Asset Portfolio Management

Issue/Introduction

The following error appears when attaching a role to a search:
You cannot assign role :<rolename> to the search because the role cannot access the following fields: <field list>

Environment

ITAM 17.x

Cause

The field(s) are not exposed for that role.

Resolution

Check all configurations that are assigned to the role. If any do not have all fields from the search exposed, expose them to the configuration.
If no configurations are found with the fields hidden, check the global configuration across all families. Expose all fields in the search to the global configuration.

Steps:

1. Log as admin > Administration > User/Role Management > Role search > Click on the role that shows up in the error message.

2. Click on Role Configuration and take note of all configurations in the list. A screenshot will also be helpful.

3. Go to Asset tab > Configure ON 

4. Click on the magnifying glass icon and click on the first configuration in the list of step 2.

5. Check if the field that appears in the error message is exposed. If not, expose the field from hidden fields and save changes.

6. Repeat steps 2 to 5 for each configuration in the list.

7. If the issue remains, expose the field in the global configurations.